Service Outage
Incident Report for Garmin Aviation
Resolved
Aviation services are fully operational. We are currently experiencing a higher than normal call volume, but our call centers are fully capable at this time. We are working to address all calls as quickly as possible and apologize for any inconvenience.

Our services are operational and we are monitoring them at this point.
Posted Jul 27, 2020 - 16:28 EDT
Monitoring
We are currently experiencing an outage that affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Our services are operational and we are monitoring them at this point.

Garmin Pilot Apps: Operational
FlyGarmin: Operational
Connext Services: Operational
FltPlan.com: Operational
Posted Jul 27, 2020 - 10:23 EDT
Update
We are currently experiencing an outage that affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Our services are operational and we are monitoring them at this point.

Garmin Pilot Apps: Weather and Routing are unavailable

FlyGarmin: Operational
Connext Services: Operational
FltPlan.com: Operational
Posted Jul 27, 2020 - 10:19 EDT
Identified
We are currently experiencing an outage that affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Our services are operational and we are monitoring them at this point.

Garmin Pilot Apps: Weather and Routing are unavailable
FlyGarmin: Offline

Connext Services: Operational
FltPlan.com: Operational
Posted Jul 27, 2020 - 09:18 EDT
Update
We are currently experiencing an outage that affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Our services are operational and we are monitoring them at this point.

Garmin Pilot Apps: Weather and Routing are unavailable
FlyGarmin: Offline

Connext Services: Operational
FltPlan.com: Operational
Posted Jul 27, 2020 - 09:16 EDT
Monitoring
We are currently experiencing an outage that affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Our services are operational and we are monitoring them at this point.

Garmin Pilot Apps: Operational
FlyGarmin: Operational
Connext Services: Operational
FltPlan.com: Operational
Posted Jul 26, 2020 - 00:18 EDT
Update
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Garmin Pilot Apps: Largely operational, exception is Database Concierge
FlyGarmin: Degraded performance during database updates

Connext Services: Operational
FltPlan.com: Operational
Posted Jul 24, 2020 - 17:27 EDT
Identified
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Garmin Pilot Apps: Largely operational, exception is Database Concierge

Connext Services: Operational
FlyGarmin: Operational
FltPlan.com: Operational
Posted Jul 24, 2020 - 16:03 EDT
Monitoring
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Connext Services: Operational
Garmin Pilot Apps: Operational
FlyGarmin: Operational
FltPlan.com: Operational
Posted Jul 24, 2020 - 15:07 EDT
Update
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Connext Services:
- Down: CMC, position reports
- Up: phone/SMS via Iridium, weather

Garmin Pilot Apps: Operational

FlyGarmin: Operational
Posted Jul 24, 2020 - 14:29 EDT
Update
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Connext Services:
- Down: CMC, position reports
- Up: phone/SMS via Iridium, weather

Garmin Pilot Apps:
- Down: weather
- Up: flight plan filing, briefing, Database Concierge

FlyGarmin: Operational
Posted Jul 24, 2020 - 13:05 EDT
Update
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Connext Services:
- Down: weather, CMC, position reports
- Up: phone/SMS via Iridium

Garmin Pilot Apps:
- Down: Flight plan filing unless connected to FltPlan, account syncing, database concierge
- Up: largely functional - weather and other real-time aeronautical data are operational

FlyGarmin: Degraded performance, database downloads are active
Posted Jul 24, 2020 - 09:38 EDT
Identified
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any emails or chats, but do have limited availability for calls. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Connext Services:
- Down: weather, CMC, position reports
- Up: phone/SMS via Iridium

FltPlan: - Fully operational

Garmin Pilot Apps:
- Down: Flight plan filing unless connected to FltPlan, account syncing, database concierge
- Up: largely functional - weather and other real-time aeronautical data are operational

FlyGarmin: Down
Posted Jul 23, 2020 - 21:42 EDT
Update
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any calls, emails, and chats. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.

Connext Services:
- Down: weather, CMC, position reports
- Up: phone/SMS via Iridium

FltPlan:
- Fully operational with exception of Mexican eAPIS

Garmin Pilot Apps:
- Down: Flight plan filing unless connected to FltPlan, account syncing, database concierge
- Up: largely functional - weather and other real-time aeronautical data are operational

FlyGarmin: Down
Posted Jul 23, 2020 - 13:56 EDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2020 - 08:49 EDT
Investigating
We are currently experiencing an outage that affects flyGarmin and as a result, the flyGarmin website and mobile app are down at this time. This outage also affects our call centers, and we are currently unavailable to receive any calls, emails, and chats. We are working to resolve this issue as quickly as possible and apologize for this inconvenience.
Posted Jul 23, 2020 - 08:43 EDT
This incident affected: Connext Services (Satellite Voice, SMS, Weather, Position Reports), CMC Maintenance Data, FltPlan.com, flyGarmin.com, and Garmin Pilot Data Services.